Unable to launch a session cluster returning 400 Bad Request
Issue
In Ververica Cloud BYOC, launch a session cluster in a workspace may give you a HTP failure response with 400 Bad Request error
Environment
Ververica Cloud BYOC
Root Cause
This issue may be specific to the BYOC workspace. The SQL service agent pod running in the BYOC cluster cannot access the workspace S3 bucket `ververica-byoc-cluster-v2-byoc-*`. Although the appmanager can obtain STS credentials successfully, the SQL service agent in the BYOC cluster uses its own credentials to access the bucket through IRSA, an IAM role, or an STS token. If those credentials are expired, missing, or misconfigured, the cluster launch fails.
Resolution
If the credentials of the SQL service agent running inside your BYOC cluster are expired or missing or misconfigured, please update them. You can check if in vvp-sql -> application-prod-user.yaml configmap has S3 region setup or not? If not, you might need to set it up and then restart the vvp-sql-0 pod. The config could be something like below:
vvp:
ui:
refreshMs: 10000
blobStorage:
baseUri: s3i://vvc-tenant-AAA-regionXXX
credentialsDir: /vvp/secrets/blob-storage-creds
s3:
region: regionXXX